服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202107-1003

摘要:postgresql漏洞 安全等级:重要 公告ID:KYSA-202107-1003 发布日期:2021-07-23 影响CVE:CVE-2021-32027

详细介绍

1. 修复的CVE信息

  • CVE-2021-32027

  • 描述:在 postgresql 中发现修改某些 SQL 数组值时,缺少边界检查,允许经过身份验证的数据库用户将任意字节写入服务器内存的广泛区域。此漏洞的最大威胁是数据机密性和完整性以及系统可用性。


2. 影响的操作系统及修复版本

  • 中标麒麟高级服务器操作系统 V7

    postgresql-9.2.24-7.el7_9

  • 银河麒麟高级服务器操作系统V10

    postgresql-9.2.24-7.el7_9


3. 受影响的软件包

  • 中标麒麟高级服务器操作系统 V7

x86_64: postgresql

aarch64: postgresql

  • 银河麒麟高级服务器操作系统V10

x86_64: postgresql

aarch64: postgresql


4. 修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

中标麒麟高级服务器操作系统V7:

x86_64:http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/aarch64/

银河麒麟高级服务器操作系统V10:

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/aarch64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename

5. 软件包下载地址

  • 中标麒麟高级服务器操作系统V7

postgresql x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/x86_64/Packages/postgresql-9.2.24-7.el7_9.x86_64.rpm

postgresql aarch64软件包下载地址: 

http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/aarch64/Packages/postgresql-9.2.24-7.el7_9.aarch64.rpm

注:其他相关依赖包请到相同目录下载

  • 银河麒麟高级服务器操作系统V10

postgresql x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/x86_64/Packages/postgresql-9.2.24-7.el7_9.x86_64.rpm

postgresql aarch64软件包下载地址: 

http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/aarch64/Packages/postgresql-9.2.24-7.el7_9.aarch64.rpm


上一篇: KYSA-202107-1002 下一篇: KYSA-202108-1001

试用

服务

动态

联系